
SketchUp Basics 
 

Important: Before viewing or downloading the SketchUp Basics video via the links provided in the 

section titled Viewing & Downloading SketchUp Basics, be sure to read the entire document and follow 

the instruction in the section titled Installing & Setting Up SketchUp On A Windows PC Platform or 

Installing & Setting Up SketchUp On A Mac OSX Platform as appropriate. 

SketchUp Basics video, and this document, are intended to give a SketchUp beginner the knowledge 

needed to create a SketchUp file, use the basic tools to create components, and assemble components 

into a model. It is assumed that the beginner has sufficient computer knowledge to install applications, 

navigate folders, create-save-and-op files and browse the internet. This course is intended to get you 

started with SketchUp. Once you are comfortable with the basics you should explore other, more 

advanced, videos and books. I will suggest some sources for advanced study and provide access to them 

in the section called Sources of Help & More Advanced Tutorials. 

CabWriter is compatible with the following SketchUp versions: 

1. SketchUp Make 2017 (This version of SketchUp is free and CabWriter HOME is compatible with 

it. CabWriter Pro and CabWriter CNC is not compatible with this version of SketchUp.) 

2. SketchUp Pro 2017 through SketchUp Pro 2019 and later. 

CabWriter is not compatible with any of the cloud based versions of SketchUp. 

SketchUp is available for both Windows PCs and Mac OSX 64-bit platforms. This video is produced on a 

Windows 10 PC. We will provide information on the video and/or in this document where there are 

differences on the Mac OSX platform. 

INSTALLING & SETTING UP SKETCHUP ON A WINDOWS PC PLATFORM 

1. Download and install SketchUp from one of these sources: 

SketchUp 2017 or 2018 - https://help.sketchup.com/en/downloading-older-versions 

SketchUp 2019 - https://www.sketchup.com/plans-and-pricing/sketchup-pro 

2. Download the file below and save it to your desktop.  

 

https://www.dropbox.com/s/k85tobobjzblljr/Template.skp?dl=0 

 

3. Open the file downloaded in Step 2 by clicking on its icon. This should open SketchUp with a file 

called Template.skp. 

 

4. Metric users should go to Window > Model Info and choose the Units page. Set this page up as 

shown in Figure 1. 

  

https://help.sketchup.com/en/downloading-older-versions
https://www.sketchup.com/plans-and-pricing/sketchup-pro
https://www.dropbox.com/s/k85tobobjzblljr/Template.skp?dl=0
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5. Close the Model Info dialog box if opened in Step 4. 

 

6. Choose File > Save As Template. A dialog box will open where you can give the template a name, 

description and file name. Be sure the ‘Set as default template’ checkbox is checked. 

 

7. Click on Save to save the template. In the future, each time a new file is created you will start 

with this template. 

 

8. Go to View > Toolbars… 

 

9. A dialog box will open. Set it up as shown in  Figure 2 and Figure 3. You will not have all the 

checkboxes shown, but you should have those that are checked, which you should check in your 

dialog box. 

 

10. Close the Toolbars dialog box .  

Figure 1 Measurement Units for Metric Users 
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Figure 3 Bottom of Toolbars list 

Figure 2 Top of Toolbar list 
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11. Arrange your toolbars as shown in Figure 4 by dragging them and dropping them into place. 

12. Go to Window > Default Tray and check both Entity Info and Layers. You will have to choose this 

command twice to check both. See Figure 5. 

Figure 4 Arrange Toolbars as shown 

Figure 5 Set the Entity Info and Layers dialog boxes to visible 
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INSTALLING & SETTING UP SKETCHUP ON A MAC OSX PLATFORM 

1. Download and install SketchUp from one of these sources: 

SketchUp 2017 or 2018 - https://help.sketchup.com/en/downloading-older-versions 

SketchUp 2019 - https://www.sketchup.com/plans-and-pricing/sketchup-pro 

2. Download the file below and save it to your desktop.  

 

https://www.dropbox.com/s/k85tobobjzblljr/Template.skp?dl=0 

 

3. Open the file downloaded in Step 2 by clicking on its icon. This should open SketchUp with a file 

called Template.skp. 

 

4. Metric users should go to Window > Model Info and choose the Units page. Set this page up as 

shown in Figure 6. 

 

  

5. Close the Model Info dialog box if opened in Step 4. 

 

6. Choose File > Save As Template. A dialog box will open where you can give the template a name, 

description and file name. Be sure the ‘Set as default template’ checkbox is checked. 

Figure 6 Model Info Units page 

https://help.sketchup.com/en/downloading-older-versions
https://www.sketchup.com/plans-and-pricing/sketchup-pro
https://www.dropbox.com/s/k85tobobjzblljr/Template.skp?dl=0
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7. Click on Save to save the template. In the future, each time a new file is created you will start 

with this template. 

 

8. Go to View > Tool Palettes and choose Large Tool Set if it is not already chosen. Uncheck all 

others that are checked. 

 

9. Go to Window and check both Entity Info and Layers. You will have to choose this command 

twice to check both. 

 

10. Go to menu View >  Customize Toolbar... OR right click on the Toolbar and choose 

Customize Toolbar. A window will open with all the available tool icons on it, including any 

plug-in tool icons. You may need to use the scroll bar to see them all. Clear the Toolbar by 

dragging anything on the Toolbar into this window. Then, from this window drag and drop 

the following onto the Toolbar. 

a. Undo/Redo 

b. Styles 

c. Standard Views 

d. Layers 

 

11. Close the Toolbar dialog box by clicking Done in the lower right corner. Your SketchUp work area 

should look like Figure 7. 

Figure 7 Work Area with Large Tool Set, Undo/Redo, Styles, Standard Views and Layers tool sets 
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SKETCHUP BASICS VIDEO 

COVERED IN THIS VIDEO 
As mentioned earlier, this is a SketchUp Basic video tutorial. We will cover the basic tools and 

procedures. 

Drawing Tools 

1. Select – The Select tool is used to make selections. It may seem too basic, but there are several 

ways to use the Select tool that makes it very powerful. 

2. Line – The Line tool creates a line or edge. It falls in the class of geometry called primitives. A 

line or edge created with the Line tool has end points and a center point. 

3. Rectangle – The Rectangle tool is used to draw rectangles which is also a primitive geometry. 

Each edge of the rectangle produced by the Rectangle tool has end points and a center points. 

The end points are also called vertices. The rectangle will be filled with a face, also a primitive. 

4. Circle – The Circle tool is used to draw circles. Note: The Circle tool does not actually draw 

circles; rather it represents a circle with an approximation of 24 line segments for a 

circumference as a default. The user can change the number of line segments to a larger 

number for better rendering quality, but at the cost of file size and performance. When drawn 

the circle will have a face primitive as well as edges with end points (vertices) and midpoints. 

5. Arc – The Arc tool is used to draw arcs formed by a center and two points on it circumference. 

Like the Circle, the arc is approximated by 12 line segments by default. This default can also be 

changed, just like the circle. 

6. Push/Pull – The Push/Pull tool is used to produce a 3D object by extruding a face in a direction 

perpendicular to the face. Using the Push/Pull tool will create additional edges and faces. The 

Push/Pull tool, along with the Rectangle tool is perhaps the most frequently used tools of all the 

SketchUp tools. 

7. Make Component – When a 3D object has been produced it should immediately be made into a 

component. Components are a collection of primitives (or entities) that are protected from 

accidental change. To change a component you must use the Edit Component command. 

8. Edit Component – as mentioned in 5, the Edit Component tool is used to make intended 

changes to a component. Only one component can be changed at a time. 

9. Move – The Move tool is used to move a selection of primitives and components to a different 

position in 3D space. It can also be used to copy and move a selection by depressing the Ctrl key. 

10. Eraser – The Eraser tool is used to erase or delete a selection of primitives and/or components. 

11. Rotate – The Rotate tool is used to rotate a selection or primitives and/or components in 3D 

space. This is generally done in one of the three primary planes, but can be accomplished in any 

plane. 

12. Offset – The Offset tool is used to create a set of edges offset a specified distance from a set of 

reference edges. 

Measurement & Labeling Tools 

1. Tape Measure – The Tape Measure tool is used to measure distances. No rounding is performed 

by the Tape Measure tool, so measurements that are not precise will be preceded with a tilde 
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(~) to indicate approximately. The Tape Measure tool is also use to create construction line and 

guide points to assist in modeling. 

2. Dimension – The Dimension tool is used to dimension drawings or scenes. The Dimension tool 

does round based on the resolution chosen in the Model Info Units pane. It should only be used 

for labeling scenes with dimensions; it should not be used to check the accuracy of a dimension. 

That is done with the Tape Measure tool. 

3. Protractor – The Protractor tool is used to measure angles and to create construction lines and 

construction points. 

4. Text – The Text tool is used to label scenes with alpha/numeric text. It also aids labeling by 

suggesting a label. The suggestion can be overridden by the modeler. 

Navigational Tools 

It is highly recommended that a mouse with a left button, right button and scroll wheel be used when 

modeling with SketchUp. 

1. Orbit – The Orbit tool is used to orbit the entire model in 3D space. The scroll wheel can be 

depressed and held to act as the Orbit tool and can also be scrolled to Zoom in and out. This 

makes it the primary tool for navigation around the model. 

2. Pan – The Pan tool is used to navigate the model in the screens horizontal and vertical direction. 

3. Zoom – The Zoom tool is used to navigate the model bringing it closer or further away. The scroll 

wheel is the primary way of zooming in or out. 

4. Zoom Window – The Zoom Window tool permits the user to select an area of the screen and 

then zooms to fill the screen with that selection. 

5. Zoom Extents – The Zoom Extents tool will fill the screen with the entire portion of the model 

currently rendered. The Zoom Extents is also used to correct for a camera position that is so 

close as to cut off parts of the model. 

Procedures 

1. Creating Layers – Layers are used to organize a model and to provide a means, along with 

scenes, to create sub-assemblies or collections of parts. You will learn to create layers and to 

move selected components to those layers. 

2. Creating Scenes – Scenes are used to organize a model and to provide a means, along with 

layers, to create sub-assemblies or collections of parts. 

3. Dimensioning and Labeling – While creating a model layers and scenes are added to organize it 

into sub-assemblies and collections of components. When the model is entirely completed, and 

deemed correct, the Dimension, Text, Tape Measure and Protractor are used to add dimensions 

and labels. 

4. Creating Exploded Scenes – Exploded scenes are a unique style of scene that allows the user to 

show subassemblies (or entire models) with the components offset from one another. T his is a 

scene that indicates how things go together and is useful for assembly instruction drawings. 
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VIDEO TIMELINE 

RUNNING TIME 1:11:55 
Time Feature 

1:08 Welcome To SketchUp Basics 

1:21 Select Tool 

1:52 The Instructor 

4:36 Line Tool 

11:58 Eraser Tool 

12:41 Rectangle Tool 

 13:57 Push/Pull Tool 

15:06 Make Component 

19:41 Move Tool 

20:32 Move/Copy Tool 

21:59 Creating Layers 

24:07 Offset Tool 

28:41 Tape Measure Tool 

33:03 Orbit Tool 

33:55 Edit Component 

34:51 More Tape Measure Tool Features 

37:05 Arc Tool 

39:53 Circle Tool 

42:23 Rotate ool 

44:26 Protractor Tool 

45:20 Pan Tool 

45:59 Zoom Tool 

46:20 Zoom Extents 

46:46 Zoom Window 

47:12 Creating Scenes 

50:57 Dimensioning & Labeling A Scene 

51:02 Dimension Tool 

52:38 Ext Tool 

58:30 Creating Exploded Views 

 

INSTALLING EXTENSIONS 

As the user gains confidence using SketchUp, it will be beneficial to add functionality by installing 

SketchUp extensions. There are thousands of extensions the can be downloaded from the SketchUp 

Extension Warehouse, most of which are free. The CabWriter Web Site also has some free extensions 

you may find useful. The can be downloaded here. 

We maintain a SketchUp Extension Installation Procedure in PDF format which provides instructions for 

installing any SketchUp extension. 

https://extensions.sketchup.com/
https://extensions.sketchup.com/
https://www.cabwritersoftware.com/free-plugins/
https://www.dropbox.com/s/0ixm85p1ddrfihh/SketchUp%20Extension%20Installation%20Procedure.pdf?dl=0
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SOURCES OF HELP & MORE ADVANCED TUTORIALS 

You can write me at jpz@srww.com with SketchUp questions and I will answer, usually within 24 hours. 

Please be clear and detailed about your question and accompany your email with a copy of your 

SketchUp model .skp file. 

Here is a list of books and videos that take you beyond the SketchUp Basics video. 

1. SketchUp - A Design Guide for Woodworkers: Complete Illustrated Reference by Joe Zeh. 

 

This book was written by yours truly as a complete instruction for woodworkers using SketchUp 

to model and produce shop drawing of their furniture. It is an in depth study of SketchUp, 

including dovetailed drawers, tapered components, complex curves, compound miters, splayed 

legs and much more. It was written using SketchUp 2015 on the Windows PC platform, and 

though some icons and dialog boxes have changed, the user should have no problem mapping 

those changes of later versions. An appendix section provides help for Mac OSX users. 

2. On our SketchUp Training page you will find a video titled Basic SketchUp for Woodworkers. This 

video covers the same material as Parts 1 & 2 of the SketchUp - A Design Guide for 

Woodworkers: Complete Illustrated Reference book. It does not cover Part 3 of the book which 

deals with splayed legs, compound miters, complex Bezier curves and compound dovetails. 

 

This video is free to anyone who purchases a CabWriter product. It is available to others at $40. 

3. Intermediate SketchUp 2014 for Woodworkers covers Part 3 of the SketchUp - A Design Guide 

for Woodworkers: Complete Illustrated Reference book which deals with splayed legs, 

compound miters, complex Bezier curves and compound dovetails. 

4. SketchUp to LayOut by Matt Donley is a good source for learning SketchUp LayOut. SketchUp 

LayOut comes with SketchUp Pro and is used by CabWriter to produce professional shop and 

architectural drawings. Though written for SketchUp LayOut 2015, it is still applicable to later 

versions. 

VIEWING & DOWNLOADING SKETCHUP BASICS 

When you have read and followed all the instructions in this document you can click one of the links 

below to view SketchUp Basics and follow along with your own model. 

Download SketchUp Basics to view on your own system. 

View SketchUp Basics via an on-line YouTube stream. 

Download SketchUp Basics Model File  

mailto:jpz@srww.com
https://www.amazon.com/Woodworkers-Complete-Illustrated-Guide-Sketchup/dp/1440342016
https://www.cabwritersoftware.com/education/sketchup-training/
https://www.amazon.com/SketchUp-LayOut-essential-construction-documents-ebook/dp/B00OHO8YLC
https://www.dropbox.com/s/hrb4og12gxyk32d/SketchUp%20Basics.mp4?dl=0
https://youtu.be/8tPUSXMF-OY
https://www.dropbox.com/s/x3jjwvkjasbwuqb/SketchUp%20Basics.skp?dl=0
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APPENDIX - PREFERENCES 

In this appendix are the SketchUp Preferences that the user should set up. Go to Window > Preferences 

and choose each pane in the left hand column and set it up as shown in the figures that follows. 
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The Files dialog box should be left as set when first installed until the user learns how to customize it as I 

have done for my setup. 
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Leave this dialog box as set up by installation. 

 

 

Leave this dialog box as set up by installation. 
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Leave this dialog box as is. In the INSTALLING & SETTING UP SKETCHUP Step 6 you created a template 

and saved it as the default template. It should be reflected here. 

 

You may wish to uncheck ‘Use large tool buttons’ if your eye sight is good. 


