
CabWriter 3.1.1 Release Notes – 10-7-2019 

New Functionality 

1. Updated the CabWriter 3 with CutList Bridge DXF User’s Guide. Importantly, I updated the 

Guidelines and Rules of CabWriter Use section to explain what characters must not be used in 

creating file and folder names. Using these characters can result in unpredictable behavior. I 

added a new guideline/rule which I am adding below for your review. 

 

“1. CabWriter uses the model’s file name and the names of components to generate folder and 

file names. In addition, you are sometimes asked to supply a file or folder name, such as when 

saving a Defaults file. 

 

To ensure the name you supply is valid for use as a file or folder name across all Windows and 

Mac operating systems and file formats, the following rules must be followed. 

 

Do not use these illegal Characters: / \ : * ? " < > | . ^ , 

Avoid using spaces. Instead use hyphen or underscore. 

 

Here are some specific cases where you must be careful of naming: 

a. When using File > Save As to save a project file for the first time and give it a name. This 

name is also used to create the Project Name on the CabWriter Settings Project tab. 

b. When changing the Project Name on the CabWriter Settings Project tab. 

c. Creating a component name, either with Make CabWriter Component or Entity Info. 

d. When using the Save CabWriter Defaults to save a defaults file with a user supplied 

name. 

e. Any time you supply a string of characters that will ultimately be used as a file or folder 

name.” 

2. Fixed a problem when printing labels. If Resized Dimensions (RD:) was chosen for any of the five 

Label Line(s), incorrect result would be displayed. 

3. Fixed a problem where a 

component had exactly the 

same bounding box dimension 

for length and width. When DXF 

files were called for it would 

end up in an error similar to 

that at right. 

 

 

  



4. This change might be also filed under Fixes. Changed the menu command File > CabWriter > 

Create Basic Scene Set to include all layers that contain a CabWriter component(s) in the CutList 

scene. This means if a component has a CabWriter prefix such as C11LCP Large Island Top, the 

layer it resides on will be included in the Cut List scene. In the past if for example, Doors & 

Drawer Fronts were placed on the DXF scene, they were then loft off the Cut List scene and the 

user would get the following error message when using File > CabWriter Production 

Documentation. 

 

 
 

5. Changed the Draw > CabWriter > Create Section From Section Plane menu command so that the 

user can select a current section plane, even if it is not the active section plane (a section cut is 

not displayed), include it with the cabinet(s) selection, and use this command. CabWriter will 

make the selected section plane active and produce the scene. 

Fixes 

1. Changed the name of the Assign Layers dialog box to Assign Layers to Scenes to be more 

descriptive and accurate. This is the dialog box that appears with menu File > CabWriter > 

Create Basic Scene Set. 

2. Added an error message that will appear when no section cut can be made from the Draw > 

CabWriter > Create Section From Section Plane menu command. 

3. Corrected the Shelf/Fixed Shelf parameter in the CNC Milled Faces section or the CNC Setup tab 

to a default setting of Top. This is to allow the DXF file generation to mill the tongue including its 

rabbet. 

  



CabWriter 3.1.0 Release Notes – 7-15-2019 

New Functionality 

1. Added an additional DXF output organized by sheet thickness & material name as before, but 

which contains individual part (instance) DXF files, one for each part (instance). The example 

Production Documentation dialog box is shown below. 

 

 

 

Nothing has changes with any of these reports: Drawer Fronts, Drawer Boxes, Doors, 

Spreadsheet Compatible Cut List or any of the three CutList Plus fx report selections. The only 

report affected is DXF by Material Name & Thickness. 

 

With this change there will be two DXF outputs: the usual DXF Files, now called Integrated DXF 

Files; and the new Individual DXF Folders. 

 

Let’s start by looking at the folder that contains the model file, but after the above CabWriter 



Production Documentation is completed. 

 

 
 

Notice the model file at the right has a file name of Gracie Hopkins Kitchen – Part 1 and an 

extension of .skp. This is the model being used in the upcoming CabWriter Comprehensive 3 

multi-part video series. The competition of a File > CabWriter Production Documentation 

operation places a folder in the same folder as the model file is in, but with a name equivalent 

to the Project Name. The Project name is the name in the Project Name section of the Project 

tab. This is generally the same name as the model file name, but in this case they differ by the 

inclusion or absence of “ – Part 1” . The folder placed in this folder, along with the model file, 

contains three files and another folder as follows. 

 

 
 



The file with the .cwx extension is the CutList Plus fx version of the cut list. Notice it has the 

same name as the model file name: NOT the Project Name. There is also a file with a .csv 

extension with the same name as the model file name. This is the spread sheet version of the 

cut list. Then there is the door and drawer schedule which is a spread sheet file with the .csv 

extension. Lastly, there is a folder with the same name as the model file: again NOT the Project 

Name. Let’s look at its contents. 

 

 
 

The CW_DXF_Files is the usual output resulting from a CutList Plus fx with DXF selection in the 

Select Desired Reports section of the Production Documentation dialog box. I won’t explain that 

further because there is no change in this report. 

 

The Integrated DXF Files is the same as the DXF Files that use to be produced by the DXF by 

Material Name & Thickness report except Integrated has been added to its name to distinguish 

it from Individual DXF Folders. Both Individual DXF Folders and Integrated DXF Files folders are 

produced now with this DXF by Material Name & Thickness report. So let’s look at the new 

report. 

 



Notice it contains a number of folders: one for each material thickness and material name. 

 
 

Within each of these folders is a collection of individual part (instance) DXF files; one for each 

part (instance) that must be placed on that sheet thickness of that material name. The names of 

these files is the name of the component the instance belongs to followed by “_i” where I is an 

integer starting with 1 and going to the number of instances of the component. Let’s look at the 

contents of 0.75in_Maple Plywood – Pre-Finished. 

 

 
 

There are 233 files in this folder, one for each part (instance). Occasionally there are more than 

one instance of a component such as the C1LB1 Shelf component shown in the red rectangle. 

 



The reason that both Individual DXF Folders and Integrated DXF Files folders are produced is 

that some models of CNC machines and its software needs to see both. 

 

2.  

 

 

  



Fixes 

1. Fixed a problem where CabWriter Production Documentation would error if producing a DXF file 

and one of Prefix 1, Prefix 2 or Prefix 3 entries on the CNC Setup tab DXF Layers section was left 

blank. Blank is a legitimate default (almost all other defaults in CabWriter require a valid input 

but not blank), but CabWriter did not correctly account for it. Below is an example of defaults 

that would result in this error. These same defaults now work with this fix. 

 

 
 

2. Fixed a problem where, when creating cut list with either CabWriter Production Documentation 

or CutList Bridge, if a cut list already existed the new cut list would be appended to it instead of 

the file being re-written. This would create a cut list with multiple component requirements. 

3. Fixed a problem where different cabinets could be  assigned the same cabinet number if the 

user manually assigned a number(s) to cabinets that were larger than the counter kept in 

CabWriter. This release should be installed before viewing CabWriter Comprehensive 3. 

4. Fixed a problem where drawing upper cabinets with Construction Method set to Inset and Back 

Attachment Method set to Inset Sides & Bottom would result in an incomplete bottom with 

faces and edges missing. 

5.  

 

  



CabWriter 3 Release Notes – 7-1-2019 

New Functionality 

1. Made a minor change to the File > CabWriter > Create Basic Scene Set tool. Limited the Ladder Plan 

scene to only walls and toe kick parts (CxxLTK prefix). This keeps other components such as face 

frame, end panel or back panel components which extend to the floor from being shown in the 

Ladder Plan scene. 

2. Made a parameter name change on the CNC Boring tab to more accurately reflect the function of 

the parameter. In the Planted Back Construction Holes section changed the parameter Top & 

Bottom Margin to Edge Margin. 

3. Changed two Factory Settings defaults on the Line Boring tab. In the Base Cabinet section Back Row 

Reference Point was changed from Front to Back and Back Row Offset was changed from 517mm to 

37mm. This makes the base and Upper cabinets consistent and also avoids errors raised when holes 

are drawn in space. 

 

 
 

4. Added a new menu command. Draw > CabWriter > End Story Stick. This file command was added 

primarily to assist Mac users who don’t have a keyboard End key, and would prefer not to use the 

Command key because it can accidentally trigger other events. This command works just like 

pressing the End or Command key in that it signals the end of the story stick and opens the Box 

Selector dialog box. However, because it is a menu command, users can now assign any keyboard 

key to is as a hot key. 

5. Changed how the Construct Walls tool functions. 

When the first point is chosen a Provide a Wall 

Name dialog box opens. In the past the user had to 

click in the input field with the cursor to begin 

typing a name. Now the Provide a Wall Name 

dialog box appears as shown at right. A default 

sequential number will appear in the input field 

and that number is highlighted and selected. The 

user has three choices: immediately begin typing a new name, which will appear in the input field, 

followed by clicking OK; simply click OK to accept the suggested wall number; or click on Cancel to 

abort the Construct Walls tool. 

6. Added a menu command File > CabWriter to LayOut > Send Selected Scene to LayOut. This menu 

command allows the user to add a new scene, after all scenes have been sent to LayOut, and send 

just the new scene to LayOut. Alternatively, after all scenes have been sent to LayOut, the user can 



edit an existing scene and send it to LayOut. In either case the user has to go back and use the menu 

command File > CabWriter to LayOut > Hatch Sections in LayOut. 

7. Changed the trial license message from: 

 

 
 

to: 

 

 
 

This should remove any ambiguity about how to begin a trial license. 

8. Updated all license functionality to accept CabWriter 3.0 licenses and not CabWriter 1.0 or 2.0. 

9. Upgraded the CabWriter User’s Guide to version 3, though it is still incomplete and a rough draft. 

10. Changed the layer that End Sheets are placed on from Base or Upper Boxes to Base or Upper End 

Panels. End Sheets were originally placed on the Boxes layer with the rationale that they are 

typically sheet goods and cabinetmakers would likely want to cut them on a CNC machine. But with 

CabWriter 3.0 it is now easy to include Base or Upper End Panels in the DXF scene, in which case 

they will be included in the DXF file. However, it is the user’s responsibility to include the Base or 

Upper End Panels layers in the DXF scene. 

  



Fixes 

1. Fixed problems with drawer front and drawer box placement with new divided cabinets. These 

problems occurred primarily in frameless designs with no mid-rails. 

2. Fixed a problem where seven defaults on the Project tab could not be changed and saved. This 

problem was introduced by accident in CabWriter 3.0 Alpha 2. 

3. Fixed a problem where the hatch images did not appear on the Materials tab. 

4. Fixed a problem with the CabWriter Move/Copy Cabinet tool. If the user deleted a cabinet 

component, such as an end stile that was superfluous, but didn’t delete the component from the 

Component library, and then executed a Move/Copy on that cabinet and error was raised. This 

situation is now just ignored and no error is raised. 

5. Fixed a problem with coped doors. If the door was too narrow to construct and error would be 

raised. Now, instead of raising an error, it simply draws a slab door. 

6. Fixed a problem where selecting the Re-Load Factory Settings tool did not close the CabWriter 

Setting dialog box if open. 

7. Fixed a problem where, if the CabWriter Setting dialog box was open before selecting the Open and 

Load CabWriter Defaults, the CabWriter Settings dialog box would close but it would not re-open 

with the loaded defaults file. 

8. Fixed a problem with divided upper and divided base cabinets where the adjustable shelf depths 

were mis-calculated on inset backs with inset distances greater than the back thickness. 

9. Fixed a problem on the Materials tab in the Material - Hatch Association section. If a Material Name 

was specified in a given row and the Hatch Name was None, the None hatch was missing in the last 

column. 

10. Fixed a problem with the refrigerator cabinet with inset joinery. The bottom pocket was mis-

positioned too high by an amount equal to the side to floor gap. 

11. Fixed a problem with Diagonal Corner Upper cabinets. When the Top/Bottom/Stretcher/Fixed Shelf 

Joinery section, Construction Method parameter is set to Inset, the tongues on the bottom of the 

cabinet were placed near the bottom instead of the top. 

12. Fixed a problem where doors and drawer fronts could be mis-numbered and mis-named if the 

number of doors or drawers in a single cabinet exceeded nine. 

13. Fixed a problem with divided cabinet where the drawer boxes and drawer slider holes could be 

misplaced. 

14. Fixed the Production Documentation dialog box. When the user had only a Home or Pro license and 

no CNC license, the label printing side of the dialog box didn’t show up. 

15. Made cosmetic changes to the Activate CabWriter License dialog box, including leaving some 

padding on the left of the input field and keeping the labels on one line. 

16. Fixed a problem that could arise with used named door and drawer fronts. Doors and drawer fronts 

in CabWriter must always have unique and sequentially numbered prefixes. If two door or drawer 

fronts have the same prefix in their component name, but the components are different, an error is 

raised. As an example, suppose CabWriter named a slab door component C12LD1 Door Front and 

the user modified or added another door with the component name  C12LD1 Diagonal Door Front. 

This would raise an error when creating Production Documentation even though these are unique 

component names because their prefixes are not unique. In the past the user would not see the 



error unless the Ruby Console was open. Now the error creates a message like this: 

 

 
 

In this example, one of the components need to have its prefix changed to C12LD2. Be sure to do 

this with the Make CabWriter Component tool as follows: 

 

 
 

This error is the same as that in 12, and will produce a similar error message. 



17. Fixed a bug where pockets were not drawn, or not drawn correctly in frameless cabinets with inset 

joinery.  



CabWriter 3 Beta 3 Release Notes – 4-25-2019 

New Functionality 

1. Wrapped the construction of a cabinet with a rescue block to let the user know when a cabinet 

failed to  complete, even if the Ruby Console is closed. 

2. File > CabWriter > Create Basic Scene Set now creates four basic Perspective scenes using the 

CabWriter Perspective style. The four scenes are named Perspective 1 through Perspective 4. Each 

scene includes Base, Upper and Wall layers. The user can rename the scenes as desired, as well as 

reposition them using the Orbit tool and Updating the scene. Unneeded scenes can be deleted. If a 

wall is in the way of viewing its layer can be made invisible and the scene updated. 

3. The Base Plan view created by File > CabWriter > Create Basic Scene Set no longer includes the Base 

Ladder layer. The Base Ladder layer is part of the Ladder Plan view. 

4. Changed the Story Stick User Mode  

tool. When using the Story Stick, the user 

has the option to press the Alt key on the 

PC, or the Command key on the Mac, until 

the cursor changes to the user mode  

cursor. In the user mode the user can 

specify a non-standard stile width by 

clicking on the construction line a second 

time, or, instead of clicking the second 

time, by just typing in the width of the 

stick and pressing enter. This has always 

worked. However, if the user then used 

one of the re-draw tools, any non-

standard stile width was replaced with the 

standard stile width based on the 

CabWriter Settings. 

 

With this change, if the user re-draws a 

cabinet using the stored defaults, any 

non-standard width stile will remain the 

same as first drawn. If the user chooses to 

re-draw by not using stored defaults, then 

non-standard width stiles will be replaced 

with widths specified by CabWriter 

Settings. This change makes the user 

mode much more useful. 

5. Changed how Extensions > CabWriter > 

Open User’s Guide works. Previously you had to be connected to the internet for the User’s Guide to 



open because that was its source. With this change you no longer need be connected. The source of 

the file is Plugins\cabwriter\users_guide. 

6. Added a new menu command, 

Extensions > CabWriter > Customize 

CabWriter Toolbar, which brings up the 

dialog box at bottom-right of the 

previous page. The user can check or 

uncheck the tool icons which should 

appear in the CabWriter toolbar. 

Changes will not take effect until the 

SketchUp application is next opened. 

7. Changed the View License and Check for 

Updates dialog box. Removed Product 

ID (it was redundant), changed License 

Key to Base License and added CNC 

License. The new dialog box is shown at 

right. 

8. Slab doors have a new parameter on the Cut List tab; in the section called Slab Door & Drawer 

Undersizing is the parameter Edge Banding Thickness. It has a default of 3mm. Unlike all the other 

parameters on the Cut List tab, Edge Banding Thickness is an Undersizing parameter, NOT an 

oversizing parameter. Further, since it is a banding thickness, the applicable door or drawer front 

will be smaller by twice the dimension in both length and width. 



9. Changed the Printing Options and Construct Walls toolbar icons to the following respectively. 

 

10. Re-arranged the CabWriter toolbar as follows. 

 

11. Provided separate parameters for End Panel to Face Frame joinery and End Sheet to Face Frame 

joinery. The defaults are Miter and Butt respectively. 

 

 

 



12. CabWriter now provides cut list support for beaded face frames though it does not draw beaded 

face frames at this time. There are two new parameters on the Cut List tab in the Face Frame 

Oversizing section: Enable Oversizing for Beading and Bead Oversize Allowance. When the user 

Enable(s) Oversizing for Beading CabWriter will oversize the length of rails, connector stiles, mid-

rails and mid-stiles. The oversizing amount will be either one or two times the Bead Oversize 

Allowance, depending on whether the component touches another component on each end. See 

the image above New Feature 8 paragraph. 

13. Implemented the Carcass Side to Floor Gap parameter in the Refrigerator Upper section of the 

Upper Cabinets tab. This parameter works in conjunction with Carcass Sides to Floor? and holds the 

refrigerator sides off the floor by the amount of the default. 

 

14.  

 

  



Fixes 

1. Fixed a problem where an abnormally large gap would appear at the top of the door in Divided 

cabinets with only one door. 

2. Fixed another problem with the adjustable shelf in Divided cabinets being misplaced due to 

incorrect calculation of left_to_right. 

3. Fixed a problem with an error message that when occurred the error message itself would not 

appear due to a coding bug. 

4. Fixed a problem where the Entity Info dialog box would not respond after certain types of errors. 

5. Fixed a problem that allowed licenses to be activated but not used, instead requiring the user to use 

a 30-day free trial. 

6. When the user issues a Send Scenes to LayOut command, CabWriter opens the new LayOut file so 

the user can inspect the results. The next logical step is for the user to issue a Hatch Sections in 

LayOut command. But it is expected that between Send Scenes to LayOut and the subsequent Hatch 

Scenes in LayOut commands, that the user would close the LayOut file so that it is not open when 

the Hatch Scenes in LayOut is executing. Previously, if the file were left open an error would be 

raised, but the user was not informed of the error. There is now a message that instructs the user to 

close the file and try again. 

  



CabWriter 3 Beta 2 Release Notes – April 9, 2019 

New Functionality 

1. Made a change to the Scenes Used in Reports section of the Production Documents dialog box. 

Previously, the contents of the three drop down fields were saved in the PrivatePreferences.jason 

file (SketchUp’s version of the PC Registry or the Mac Plist files). This meant that they were saved 

with the application, not the model. Since the contents of these fields can be different with each 

user model (scene names are often different in each model) it made more sense to save them in the 

model (in Layer0). 

2. Added the ability to print Avery 5160 style labels with selected component information. The new 

Production Documentation dialog box looks as follows: 

 

The field selection on the left side of this dialog box are saved with the model (Layer0) when the 

Create Reports button is pressed. The field selections on the right are save with the model (Layer0) 

when any of the three buttons in the Assign Components for Printing by Report section are pressed. 

 

Notice the red box. This box will only appear when all conditions are met for choosing a Scene, from 



which to get a collection of components that will be printed on the Avery labels. The Scene that will 

be the source of these components must appear in one of the three fields in the Scenes Used in 

Reports section. In addition, the Print Labels Using: field in the Assign Components for Printing by 

Report section must point to the field in the Scenes Used in Reports section that contains the source 

Scene. 

In the example on the previous page, Print Labels Using: field is pointing to the DXF Report. The DXF 

Report field is pointing to the model’s DXF Scene. This means that every CabWriter component that 

is included in the DXF Scene, except drawer boxes, will be included in printing labels. 

The contents of the labels is selected by the Line 1: through Line 5: fields. As you select the 

information to be included the red box will be updated and show a sample label. In fact, the red box 

will be updated whenever the drop downs in the Scenes Used in Reports section are changed; when 

Line 1: through Line 5: drop downs are changes; or when the Print Labels Using: drop down is 

changed. Providing, of course, that the conditions for showing the red box are met. 

You can preview the first sheet of printout with the Print Preview button, in fact, you must press this 

button to bring up the preview page, and you must leave that page open to use the Print Labels 

button to actually print your pages of labels. You can close the preview page with the Close Preview 

button. 

It is highly recommended that you print one page of labels on plain paper first to see if the 

alignment is correct for the Avery 5160 labels. Unfortunately, this may not work on some printers 

that have built-in margins that the user cannot change. 

3. CabWriter now adds the construction holes in backs drawn with CNC Drilling Method. Below is 

shown the CNC Boring tab with their parameters and default settings. 

 

  



4. CabWriter will now add additional hinge plate holes in tall door situations providing; 

a. The project is a CNC project as indicated by the Drilling Method parameter in the General 

section of the Project tab. 

b. Shelf System Holes are disabled for the appropriate Base or Upper as indicated by the 

Enable parameter on the CNC Boring tab. 

c. The top and bottom hinge spacing is greater than the parameter Maximum Hinge Plate 

Spacing in the Hinge Plate System Holes section of the CNC Boring tab. 

The number of incremental hinges is controlled by the spacing between the top and bottom 

hinge and the Maximum Hinge Plate Spacing parameter. If the Enable parameter is Yes in the 

Base or Upper Shelf System Holes section of the CNC Boring tab, no additional hinges will be 

added. In this case it is assumed the user will use shelf holes to secure additional hinges. Notice 

the new Maximum Hinge Plate Spacing parameter in the CNC Boring tab below. 

 

5. CabWriter now provides another way to control what parts (component instances) end up in cut 

lists and DXF files. Previously the parts that are in the cut lists and DXF files were determined by the 

layers that were visible within a scene. That is still true; but now you can further control which parts 

in a scene are included or left out. 

 

Before explaining the procedure let me explain some changes. When SketchUp is opened and 

CabWriter is loaded, three style files are added to the models Styles library (dialog box). They are: 

CabWriter Perspective; CabWriter Non-Section; and CabWriter Section. It is highly recommended 

that when creating scenes in a CabWriter project that you use one of these three styles for your 

scene. CabWriter Perspective should be used for all of the perspective scenes you create. When 

CabWriter creates scenes, either with Create Basic Scene Set or Create Section From Section Plane, 

it will use the appropriate style. As their name implies, CabWriter Non-Section style is used on 



scenes such as cut lists, DXF, and elevation scenes, which don’t require a section plane. Plan views 

or elevation section views will use the CabWriter Section style. One of the parameters remembered 

by these styles is Hidden Geometry. Which brings me to the new feature, the ability to hide one or 

more parts in a scene and keep them from appearing in either the cut lists or the DXF files. 

 

As an example, suppose you want to cut all cabinet carcass parts on a CNC machine except cabinet 

C5U’s carcass parts. Here is the procedure: 

a. Select the scene that will be used to create the DXF files. Make sure the scene’s tab is active. 

b. Select the part or parts you wish to hide. DO NOT use CabWriter’s context menu selection 

tools. Doing so may select parts you don’t want selected. For example, when you select a 

cabinet using context menu CabWriter > Select Cabinet, the entire cabinet is selected and all 

you want to select is the carcass parts. So use the SketchUp native Select tool. 

c. In the Entity Info dialog box on the bottom left click the eye icon to hide the selected parts. 

d. Lastly, right click on the active scenes tab and choose Update. 

At a later date you might decide to include C5U’s carcass parts in the DXF files. Here is the 

procedure for un-hiding the hidden parts. 

a. Select the scene that will be used to create the DXF files. Make sure the scene’s tab is active. 

b. Go to the View menu and check Hidden Geometry. The hidden part will appear in a 

checkered blue outline. 

c. Select the blue outlines part(s) using the native Select tool. 

d. In the Entity Info dialog box on the bottom left click the eye icon to un-hide the selected 

parts. 

e. Go to the View menu and un-check Hidden Geometry. 

f. Lastly, right click on the active scenes tab and choose Update. 

This technique can be used to create plan or section view of just one cabinet. Simply choose all 

cabinet parts except the cabinet you want included in the scene. 

6. In CabWriter 3.0 Beta 1 we added a new tool called Move Cabinet  and Move/Copy Cabinet. In 

Beta 2 we added a companion tool, accessed only through the context menu, called Mirror Cabinet; 

Context menu CabWriter > Mirror Cabinet. To use it select one, and only one, part on any cabinet 

and then go to the Context menu CabWriter > Mirror Cabinet. Mirror Cabinet has no tool icon in the 

toolbar. This tool will prove useful in kitchens where you might want symmetry around a window, or 

in a bathroom vanity situation or even in an entertainment for symmetry around a large TV screen.  

In the example on the next page I first used the Move/Copy Cabinet tool to move a cabinet and then 

mirrored it with the Mirror Cabinet tool. 

 

Note: The Mirror Cabinet tool is a re-draw tool. Plan ahead and if you are going to use this tool; do 

not customize any cabinet parts until you have done the Move/Copy and Mirror Cabinet operations. 

  



 

 

  



7. In CabWriter 3.0 Beta 1 we added functionality to the Divided Upper and Divided Base cabinets that 

allowed 15 divisions and the automatic drawing of doors and drawers. However, not adjustable 

shelves were drawn. Our thinking at the time is that we had no idea how many shelves a user would 

want in any compartment, especially since the size of the compartment could be very large or very 

small. In Beta 2 we decided to add one adjustable shelf behind each door in the Divided Upper or 

Divided Base. Then, if the user wants more they can simply use native SketchUp tools to Move/Copy 

as many as needed. Instance names can be changed in the Entity Info dialog box. No need for 

creating a custom part and using the Make CabWriter Component tool. If no shelves are desired, it is 

a simple matter of deleting the shelf. If shelves are added or moved, consider using the Set 

CabWriter Protection tool. 

8. With each new release of CabWriter there exists the possibility on new parameters added, or old 

parameters deleted. In the past we suggested using the Re-Load Factory Settings tool when opening 

an old model from a previous CabWriter revision before opening a user defaults file. With more and 

more people using CabWriter, and each creating a library file of user defaults, we decided to add a 

new tool; menu Extensions > CabWriter > Update Defaults Files. This tool will examine all defaults 

files: Imperial, Metric and User. If it finds old parameters that have been deleted it will remove them 

from the file. If it finds missing parameters due to new parameters being added it will add them to 

the file. If it finds valid parameters that are blank it will report the file in question and the user must 

manually examine and fix that file. This tool should be used at least once on every new installation 

of CabWriter, UNLESS the user does not want theirs user defaults modified. In any case, since this is 

a Beta release, it is recommended that the user manually backs up their user defaults folder. 

 

As mentioned earlier, if a 

parameter is blank a 

message will appear like 

that at right. Notice the 

red ellipse indicates it is a 

user file and gives the 

offending file location and 

name. After the Update 

Defaults Files tool 

completes, the user can 

manually fix this by 

loading that file, 

examining each 

CabWriter Settings tab for 

the blank parameter(s), 

adding the desired default and then saving the defaults to the offending file. You may have to do 

this for more than one file. After completing the fixes it is suggested you run Update Defaults Files  

again until you get a clean pass. 

 



Update Defaults Files can take on the order of 30 seconds or more to complete. Be sure to wait for 

the message indicating completion.  



Fixes 

1. Fixed an issue where the Template drop down in the LayOut Document SetUp dialog box pointed to 

LayOut 2018 Templates regardless of SketchUp version the user was using. 

2. Fixed a problem where combo drawers would always be drawn as a solid, regardless of drawer 

height. 

3. Fixed a problem where combo draws drawn in frame and panel would be left as a group instead of 

individual frame and panel components. 

4. Fixed a problem with Create Basic Scene Set. When using this tool, without assigning hatches to 

materials, the section color should default to SketchUp’s Front color. It was defaulting to the Back 

(inside) color. 

5. Fixed an issue with CabWriter Production Documentation. If a model’s file name is the same as the 

folder’s name it resides in, and the Project name are all the same, an error would be raised with the 

message “The requested file is locked or in use by another application”. 

6. Fixed an issue with CabWriter running on SketchUp 2019. It appears that Trimble SketchUp made a 

change to the Ruby interpreter that causes a certain code configuration to evaluate incorrectly. I 

placed a bug report with SketchUp and coded a work around. This problem appears when drawing a 

Standard Base cabinet. The hinge and shelf hole configuration is as though the cabinet is a Standard 

Base w/Drawer(s). 

 

Update: SketchUp was able to reproduce the problem and is working on a fix. 

 

7. Fixed the CabWriter angle_between(uv1, uv2) method, which was not robust enough for the Mirror 

Cabinet tool; it always assumed one vector was on the positive Red or Green axis. 

8. Fixed two Undo operations which included parts of other operations. 

9. Fixed a problem where the Create Section From Section Plane tool did not set the correct style; 

CabWriter Section style. 

10. Fixed a problem where the Drawer Box report wasn’t looking at the specific component’s defaults to 

determine the drawer slide requirements. Rather it was looking at the current contents of the 

CabWriter Settings. 

11. Fixed a problem that crept in somewhere along the way that didn’t permit successful conclusion of 

Hatch Sections in LayOut. 

12. Improved a number of error messages having to do with file operations, so the user could more 

directly and easily figure out what went wrong. 

 

  



CabWriter 3 Beta 1 Release Notes – 3-12-2019 

Very Important: 

1. It is recommended that you DO NOT install and use CabWriter 3.0 Beta 1 on projects created in 

CabWriter 2.x.x. Divided Upper and Divided Base cabinets have changed significantly in CabWriter 

3.0 and they are not compatible with CabWriter 2.0. Use CabWriter 3.0 only on new projects. 

2. The CabWriter 2 with CutList Bridge DXF User’s Guide has not been updated for 3.0. However, with 

this release we are providing a video called CabWriter 3.0 Beta 1, which demonstrates the changes 

in 3.0 Beta 1. Be sure to view it on our website. 

3. Divided Base and Divided Upper cabinets no longer require the aid of Insert a Door and Insert a 

Drawer tools. These boxes/cabinets now draw the doors and drawers on their own. However, 

because we have had no user beta testing on the new Divided Base and Divided Upper cabinets to 

date, we have left these tools in to assist if there is a problem which requires their use. Once we 

establish that user’s are comfortable with the new boxes we will remove these tools. 

4. When using the Divided Upper and Divided Base boxes/cabinets, be sure to very carefully inspect 

them to be sure you are getting what you expect. Look very carefully at drawer box positioning 

(margins left, right, top and bottom) and height. The number of combinations of boxes that are 

possible is extremely large and hence makes it impossible for us to test them all. 

5. Report all errors to me at jpz@srww.com and please send along your zipped SketchUp file. 

  

mailto:jpz@srww.com


New Functionality 

1. Moved the Associate Material to Hatch dialog box to CabWriter Settings on a new tab called 

Materials. Along with this change the Materials section of the Project tab has been removed and 

placed on the Materials tab. The new Materials tab looks like the image below. 

 

 
 

Notice there are seven columns and five rows in the Material – Hatch Association section. 

Row_1:Column_1 and Row_1:Column_7 are not labeled, but the in-between columns in Row_1 

have the labels of Material Type, Material Name, Hatch Name, Rotation and Scale. Column_1 

contains four lights. These will be green only when all Material Names in Column_3 have been 

assigned a Hatch Name in Column_4 for each row; or when a row in Column_3 is blank, such as 

Dimensioned Lumber in the above image, indicating there are no Dimensioned Lumber materials 

used that need a hatch assignment. 

 

Each of the four rows labeled Rough Lumber, Dimensioned Lumber, Sheet Good and Wall may have 

more than one Material Name. To assign all Material Names the user must check the drop down 

boxes in the Material Name column. 

 

A Red light in Column_1 indicates that at least one of the Material Names in that row is missing a 

hatch association. It may not be visible until the user selects that Material Name from the drop 

down box. When a new CabWriter project has been created, and before any cabinets have been 



drawn, all four lights will be Red indicating that there are no components, hence no Material Names 

to associate a Hatch Name. 

2. Re-named and re-defined two defaults in the Materials section of the Materials tab of CabWriter 

Settings. See the image below. 

 

 
 

The End Panel default has been re-named to End & Back Panel and Back Panel default has been 

renamed to End & Back Sheet. Also notice the Slab Door/Drawer Front default has been moved up 

to the third default from the top. Here are the new definitions for End & Back Panel and End & Back 

Sheet. 

 

End & Back Panel – This default applies to the panel material in a frame and panel End Panel or Back 

Panel. 

 

End & Back Sheet – This default applies to the sheet material in an End Sheet or Back Sheet. 

 

Note: Doors and Drawer Fronts have their own panel default (Door/Drawer Panel) and sheet default 

(Slab Door/Drawer Front). 



3. The user now provides the wall name. Upon the first click of the Construct Walls tool a dialog box 

appears as shown below. The user must supply a unique and short wall name. If it is not unique 

SketchUp will append a number to the end to make it unique. The wall name provided by the user 

will be prefixed with “CW_Wall “. In the example the wall below will be named CW_Wall West. 

CW_Wall West will be placed on layer Wall, West by prefixing the name with “Wall, “. 

 

Modified the behavior of the Construct Walls tool. 

The Left Arrow key will now lock the wall to the 

Green axis; the Right Arrow Key will lock the wall to 

the Red axis. 

 

As you move the Construct Walls cursor, if any of 

the four corner points are in a negative quadrant 

the rectangle outline will turn purple and stippled 

with long dashes. This indicates an illegal placement of the wall. You might be able to fix this with 

the Ctrl key by flipping the wall to the opposite side of the starting point. Otherwise you have to 

begin the wall in another location in the model. So plan ahead before drawing walls to be sure your 

entire model will be in the positive quadrant. See example below. 

 

 

 



4. CabWriter now automatically generates the Cut List, DXF, Purchased Parts, Base Plan, Upper Plan 

and Ladder Plan scenes. Choose menu File > CabWriter > Create Basic Scene Set and the following 

dialog box appears. 

 

The user can choose which scene the Doors, Drawer Fronts 

and Drawer Boxes appear in. The default selections, shown in 

this dialog box image, are assigned using the defaults that 

appear in the Layer Assignments section of the Project tab in 

CabWriter Settings. The user can change these defaults and/or 

change the assignments in this dialog box. After pressing OK 

the automatic generation begins. 

 

The vertical positioning of the Section Planes for the Base, Upper and Ladder Plan scenes is set by 

defaults in the Section Plane Positions section of the Project tab in CabWriter Settings. The Base and 

Upper Plan Plane Positions are set to section the base and upper cabinets half way up their height 

for standard cabinets. The Ladder Plan Plane Position is set at 7/8” to capture the horizontal 

stretchers; much higher and they will be left out of the section cut. The user can change these 

defaults to alter a scene or select the appropriate section plane used in a scene and manually move 

it up or down. See the Project tab below. 

 



5. Added an option to the Box Selector and Modify Box Selector dialog boxes “Override Default Hinge 

Side?” drop down. The new option, called “No Hinge Holes” allows the user to disable hinge holes 

on a per box basis. This means you can model cabinets with doors, but no hinge holes. This default 

also, when selected, will permit the “Insert a Door” tool to add a door without hinge holes when 

using the cabinet’s stored defaults. See image below 

 

6. Changed the Divided Upper and Divided Base to draw doors and drawers automatically by on user 

inputs in the Divided Box dialog box. Note the changes in the Box Selector and Modify Box Selector 

dialog boxes and the new Divided Box dialog box at the top of the next page. 

 

The user now has 15 compartments to define. Each time the ‘Select a box type.’ Dropdown is 

selected to Divided Base (or Divided Upper) the Divided Box dialog box (right image) opens. The user 

must complete the Divided Box and press OK before going to the next box using the Next button on 

the Box Selector (or Modify Box Selector) dialog box (left image). The values in the Divided Box 

dialog box, at the top of the next page on the right, produced the left box in the cabinet at the top of 

the following page. Note that the user no longer needs to use the Insert a Door and Insert a Drawer 

tools. 

 

7. Changed the None Hatch to white from gray. 



8. Moved the Fixed Shelf Offset parameter from the Base Cabinets tab to the Carcass tab in the Shelves  

section. This is to reflect that this parameter is used in both Divided Upper and Divided Base boxes. 

Also changed the default from 0” to 5/8”. 

 



 

 

9. Added a new tool called Move Cabinet  and Move/Copy Cabinet. As the icon suggests, what it 

actually does is accepts two endpoints from the user. Both points must be on a construction line. 

The initial point is interpreted as the new starting point for the moved or copied cabinet. The second 

point can be any distance from the initial point and is interpreted as the direction (a vector) the 

moved or copied cabinet will be drawn. The Ctrl key (Option key on the Mac) will toggle Move and 

Move/Copy, indicated by the presence or absence of a + sign on the cursor.  



Fixes 

1. Disconnected the Offset input field in the Divided Base Options and Divided Upper Options sections 

of the Box Selector and Modify Box Selector dialog boxes from Mid-Stretchers. Also rename Offset 

to Fixed Shelf Offset. The result is that Fixed Shelf Offset only applies to Fixed Shelf(s), not to Mid-

Stretchers. This solved a problem with pockets being drawn incorrectly in upper divided cabinets 

and the mid-stretchers being placed incorrectly in both base and upper cabinets. 

 

In addition, changed the Component Type for Fixed Shelf from Bottom to Shelf, which changes its 

CutList Bridge attribute. Lastly, on the CNC Setup tab, changed the default Shelf/Fixed Shelf in the 

CNC Milled Faces section from Bottom to Top. These two changes permitted the correct DXF 

drawing of mid-stretchers; specifically it permitted the drawing of the rabbets on the tongues. 

2. Fixed a problem with the Insert a Drawer tool. If the top rail is drawn, and the user tries to insert a 

drawer that touches the top rail, the drawer opening is incorrectly calculated, making the selected 

drawer box height less than it should be. 

3. Fixed a problem with Edit Cabinet. If, for example, a Standard Base w/Drawers is drawn with two 

doors and two drawers, and subsequently the Edit Cabinet tool is used to edit another aspect of the 

cabinet, the doors and drawers would revert to one door and one drawer, even though these 

parameters were not changed. This was due to the asynchronous nature of the HTMLDialog causing 

a code race condition. 

4. Fixed a problem with an uninitialized class instance variable. If the user just completed editing a 

divided upper cabinet using Edit Cabinet, and followed that by editing any non-divided upper 

cabinet also using Edit Cabinet, any box number greater than 1 would be interpreted as a divided 

upper even though its DNA says otherwise. 

5. Fixed a problem with Divided Upper and Divided Base where the wrong set of defaults could get 

selected when using the Insert a Door tool. This would only occur when the selected rectangle 

touched more than one box and when the user was queried about the wrong box first. 

6. Fixed a problem where drawer boxes in Divided Upper cabinets were mistakenly placed on the 

Upper Drawer Fronts layer instead of the Upper Drawer Boxes layer. 

7. Fixed a problem with a bug crash would occur on the Mac when drawing a Divided Upper or Divided 

Base. 

8. CabWriter Software LLC’s website is now a secure site. Hence its new URL is 

https://www.cabwritersoftware.com/. This change required a code change because it produced 

errors when trying to activate a license. 

9. Fixed a problem that occurred frequently with models using inset joinery. The problem occurred 

seldom on models that did not use inset joinery, though it sometimes could. The typical error 

message was "The model appears to contain a component with a missing face.". 

10. Fixed a problem that restricted DXF output to 100” (2540 mm) long sheet goods. Now the user’s 

model can call for 150” (3810 mm) long sheet goods. This is intended to allow use of 12 foot sheet 

goods or its metric equivalent. 

https://www.cabwritersoftware.com/


11. After and error message, SketchUp was sometimes left in a state that required a tool such as the 

Line tool to be used before the Select tool could be chosen. Now, after an error message, the Select 

tool is automatically chosen. 

12.  

 

 

 


